Re: [css-flexbox] Renaming flex-basis:auto for less confusion

On 11/03/2014 01:45 PM, Daniel Holbert wrote:
> The second proposal would restore this oddness from the original
> spec-text ("auto" being able to pull in "auto"), though it's a bit
> better now that we have a non-"auto" keyword that we can use to describe
> the sizing behavior when this happens ("content").

I'm not sure if that weirdness is worse or the fact that switching up
'flex: auto' to 'flex: <integer> auto' fails to map straightforwardly
is worse. (Also there's the back-compat issue.) Probably if we did
this from the beginning, your way would make more sense, but with
'flex: auto' the way it is now, I'm not so sure. :/

Since we're arguing on usability, would be good to get some author
feedback on the issue. Where do we find authors who understand
Flexbox enough to grok this issue? :)


Received on Tuesday, 4 November 2014 04:35:42 UTC