Re: [css-variables] ...let's change the syntax

On Mar 17, 2014, at 12:27 PM, Bjoern Hoehrmann <derhoermi@gmx.net> wrote:

> * Sylvain Galineau wrote:
>> On Mar 17, 2014, at 12:04 PM, Bjoern Hoehrmann <derhoermi@gmx.net> wrote:
>>> I am more concerned about having to debug through
>>> 
>>> #something {
>>>   -webkit-border-radius: 5px;
>>>   width: 200px
> 
>> Sure, this can happen as long as some browser vendors preserve prefixes. 
>> But Iím not sure why this would be worse than:
>> 
>>> #something {
>>>   -webkit-border-radius: 5px;
>>>   width: 200px
>>>   -moz-border-radius: 5px;
>>>   height: 200px;
>>>   --scroll: carousel(...);
>>>   -o-border-radius: 5px;
>>>   border:radius: 5px;
>>>   --says: groovy;
>>> }
>> 
>> Öwhere the custom props carry no information as to what makes use of 
>> them. Which is harder to investigate? 
> 
> To go back to Daniel's orginal argument about author familiarity, it
> should rather be something like
> 
>  #something {
>    -webkit-border-radius: 5px;
>    width: 200px
>    -moz-border-radius: 5px;
>    height: 200px;
>    data-jquery-scroll: carousel(...);
>    -o-border-radius: 5px;
>    border:radius: 5px;
>    data-sassy-framework-says: groovy;
>  }
> 
> Where the vile ones stick out their ugly heads.

I get that you prefer to differentiate them. Iím just not convinced itís harmful if they sort of look alike. Never mind that two major browser vendors have already given up on using them for new features. 

Received on Monday, 17 March 2014 20:08:46 UTC