Re: [css-variables] ...let's change the syntax

> Using custom properties for polyfilling (while, of course,
> better than _nothing_) forces web developer to _duplicate_
> value in both standard property _and_ a custom one. Such
> duplication is totally not the same as "just _adding_ a small
> prefix to property name" as Tab likes to incorrectly advertise.

This is not entirely accurate.

    * {
        turbo-boost: var(fc_turbo_boost);
        -ms-trubo-boost: var(fc_trubo_boost);
        -moz-trubo-boost: var(fc_trubo_boost);
        -webkit-trubo-boost: var(fc_trubo_boost);
        fc_turbo_boost: var(invalid); /* or inherit if the property is 
supposed to inherit */

    /* now we can use fc_turbo_boost anywhere else in our stylesheet */

> Using `var()` for accessing something that is not a variable
> looks confusing and therefore undesirable. Something like
> `prop()` would probably be more appropriate and intuitive.
> (And `prop()` should work for any property -- not just
> custom ones. ;-)

This a different debate; one I put a lot of conviction into, but a different 
issue anyway. As I discovered, it's really hard to make good arguments stand 
out in a Custom Properties discussion because so many things get discussed 
at once. Let's stay focused on Tab's proposal for now, and *if* we resolve 
towards changing the declaration syntax, *then* we'll see if there's a need 
and volounty to reopen the usage syntax. Let's work on one thing at a time 

Received on Thursday, 13 March 2014 21:45:31 UTC