[css-writing-modes] Rename extent/measure to block-size/inline-size?

Hi,

I know itís not Last Call yet :) But what do you think of renaming 
"extent" a.k.a. "logical height" to "block size", and "measure" a.k.a. 
"logical width" to "inline size"?

I may be getting English wrong, but to me "extent" and "measure" are 
both synonymous to "size". The terms by themselves donít tell me which 
is which. I understand (after reading it in the spec) that "measure" is 
more specific in typography, but I donít know how much of the "target 
audience" is familiar with that. I wasnít.

Logical height and logical width, on the other hand, are 
horizontal-centric and kinda backwards when used for vertical text.

Gecko uses "block size" and "inline size" internally, which fits nicely 
in the pattern of the existing 
block-start/block-end/inline-start/inline-end terms.

As far as I know, these terms do not appear in CSS syntax, so this 
change would not affect implementations and would be only editorial. 
Itís still a big change, though; several other specs are using these terms.

-- 
Simon Sapin

Received on Friday, 28 February 2014 10:58:56 UTC