W3C home > Mailing lists > Public > www-style@w3.org > December 2014

Re: [css-grid] Editorial: rename the Grid Layout Algorithm section

From: fantasai <fantasai.lists@inkedblade.net>
Date: Thu, 18 Dec 2014 17:30:08 -0800
Message-ID: <54937FA0.3010806@inkedblade.net>
To: www-style@w3.org
On 04/24/2014 12:55 PM, Daniel Holbert wrote:
> On 04/24/2014 12:37 PM, Tab Atkins Jr. wrote:
>> On Thu, Apr 24, 2014 at 11:04 AM, Simon Sapin <simon.sapin@exyr.org> wrote:
>>> I suggest renaming the "Grid Layout Algorithm" section to "Track sizing
>>> algorithm"
>>
>> Done.  We moved Intrinsic Sizes to the section talking about grid containers.
>
> Hmm. One problem with this -- there was actually already a section
> implicitly labeled the "track sizing algorithm" (and linked to, using
> that term) -- halfway through section 10.2, there's the statement:
>   "The remainder of this section is the track sizing algorithm"
> which is the link target
>
> Also, earlier in Section 10.2, the spec still uses the (now undefined)
> term "grid layout algorithm", and lists "track sizing algorithm" as
> being a sub-step of that algorithm which is repeated several times.
> (which feels a bit odd inside of a section whose title is the same as
> that sub-step's name)
>
> So: it still seems like we might need a term to describe the broader
> algorithm (in which the "track sizing algorithm" is already a defined
> substep).  Or perhaps we should rename the substep.

Okay, we renamed the top-level Section 10 as "Grid Sizing Algorithm".
Let us know if there is something awkward about this. :)

~fantasai and TJ
Received on Friday, 19 December 2014 01:30:46 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:49 UTC