Re: [css-grid] Editorial: rename the Grid Layout Algorithm section

On 04/24/2014 12:37 PM, Tab Atkins Jr. wrote:
> On Thu, Apr 24, 2014 at 11:04 AM, Simon Sapin <> wrote:
>> I suggest renaming the "Grid Layout Algorithm" section to "Track sizing
>> algorithm"
> Done.  We moved Intrinsic Sizes to the section talking about grid containers.

Hmm. One problem with this -- there was actually already a section
implicitly labeled the "track sizing algorithm" (and linked to, using
that term) -- halfway through section 10.2, there's the statement:
 "The remainder of this section is the track sizing algorithm"
which is the link target

Also, earlier in Section 10.2, the spec still uses the (now undefined)
term "grid layout algorithm", and lists "track sizing algorithm" as
being a sub-step of that algorithm which is repeated several times.
(which feels a bit odd inside of a section whose title is the same as
that sub-step's name)

So: it still seems like we might need a term to describe the broader
algorithm (in which the "track sizing algorithm" is already a defined
substep).  Or perhaps we should rename the substep.


Received on Thursday, 24 April 2014 19:56:16 UTC