W3C home > Mailing lists > Public > www-style@w3.org > October 2013

Re: [css-shapes] Functional Notation

From: Alan Stearns <stearns@adobe.com>
Date: Tue, 1 Oct 2013 12:19:28 -0700
To: fantasai <fantasai.lists@inkedblade.net>, "www-style@w3.org" <www-style@w3.org>
Message-ID: <CE706D48.309E1%stearns@adobe.com>
On 10/1/13 11:53 AM, "fantasai" <fantasai.lists@inkedblade.net> wrote:

>On 10/01/2013 12:22 AM, Dirk Schulze wrote:
>>
>> On Oct 1, 2013, at 9:01 AM, fantasai <fantasai.lists@inkedblade.net>
>>wrote:
>>
>>> We adopted some general principles for functional notation:
>>>    http://wiki.csswg.org/ideas/functional-notation#general-principles
>>>
>>> This included changes to the shapes functional notations
>>> to align them with these principles:
>>>    http://wiki.csswg.org/ideas/functional-notation#shapes
>>>
>>> The resolution was recorded here:
>>>    http://lists.w3.org/Archives/Public/www-style/2012Feb/0325.html
>>>
>>> Were the edits never made, or was the resolution overturned
>>> and I didn't notice?
>>
>> If we should have agreed on them (wasn't in Paris at the time).
>> [...] It is unreasonable and unpractical to change the grammar
>> for CSS transforms for example. [...] "We recommend shortening
>> the name to rect(), and unifying with the 'clip' value." Is
>> ovetuned by followup resolutions. [...]
>
>I think you forgot to click on the link there. The resolutions
>were recorded as follows, let me quote:
>
>    RESOLVED: adopt the principles in
>http://wiki.csswg.org/ideas/functional-notation
>    RESOLVED: adopt the proposed changes to exclusions in
>              http://wiki.csswg.org/ideas/functional-notation except
>              for the suggestion to unify rect() and rectangle()
>
>None of which is inconsistent with your concerns.

The edit for polygon() was made, as that's the one that made the most
sense to me. Grouping points makes the function much more readable.

I don't understand why we'd go with commas for the color functions but not
with commas for circle(), for example. It looks like needless consistency
(or inconsistency, depending on what you're comparing to).

Thanks,

Alan
Received on Tuesday, 1 October 2013 19:19:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:51:02 UTC