[selectors4][naming] Renaming :matches() (was: Proposal: Logical Combinators / Sets)

Le 15/03/2013 14:57, Brian Kardell a crit :
> On Mar 15, 2013 9:14 AM, "Lea Verou" <lea@w3.org <mailto:lea@w3.org>> wrote:
> > FWIW, I agree that :any() is a much better name than :matches(). I
> > was always baffled by the WGs decision to name it :matches, despite the
> > existing implementations, straightforwardness and brevity of :any().
> Excellent  :-) I think it makes more sense in historical perspective
> given the use cases they were hoping to solve and the evolution of ideas
> that were being tossed around.  At this point though, any or any-of
> definitely seems more sensible.

+1 on :any() or :any-of() instead of :matches().

Simon Sapin

Received on Friday, 15 March 2013 14:09:07 UTC