W3C home > Mailing lists > Public > www-style@w3.org > August 2013

Re: [CSSOM] Revisiting transforms and getBoundingClientRect()

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Wed, 28 Aug 2013 20:01:39 -0700
Message-ID: <CAAWBYDAHFTkhtOkRFfVKhRr=X6K7Ao0ciM_OCEBe_Le7i6=OqQ@mail.gmail.com>
To: Rik Cabanier <cabanier@gmail.com>
Cc: "Robert O'Callahan" <robert@ocallahan.org>, Dirk Schulze <dschulze@adobe.com>, Simon Fraser <smfr@me.com>, Andrew Dupont <w3@andrewdupont.net>, www-style <www-style@w3.org>
On Wed, Aug 28, 2013 at 7:39 PM, Rik Cabanier <cabanier@gmail.com> wrote:
> On Wed, Aug 28, 2013 at 5:12 PM, Tab Atkins Jr. <jackalmage@gmail.com>
> wrote:
>> On Wed, Aug 28, 2013 at 4:43 PM, Robert O'Callahan <robert@ocallahan.org>
>> wrote:
>> > On Thu, Aug 29, 2013 at 10:52 AM, Tab Atkins Jr. <jackalmage@gmail.com>
>> > wrote:
>> >> Your naming is inconsistent.  Merging with the other linked thread, we
>> >> have "CSSRect", "Quad", and "DOMPoint".  You seem to have renamed the
>> >> last one to "CSSPoint" in this email, which helps, but I'm still left
>> >> wondering why it's not "CSSQuad".  (I kinda liked DOM as the prefix
>> >> for all of them, on the assumption that these things'll be useful for
>> >> more than just CSS.  Maybe we could divorce it further from "where
>> >> it's specced" notions and call them LayoutPoint/Rect/Quad?  I'd like a
>> >> name that doesn't have much friction with using these in a 3d geometry
>> >> library.)
>> >
>> > We also need to consider the Matrix work:
>> > https://dvcs.w3.org/hg/FXTF/raw-file/tip/matrix/index.html
>> >
>> > I think if we're going to use any prefix, we should use the same prefix
>> > for
>> > Point, Rect, Quad and Matrix. I'm afraid to arrogate those names as-is.
>> > Either DOM or CSS would work for me. Blink has already got an
>> > implementation
>> > of CSSMatrix so I think we may as well go with the "CSS" prefix. Yes,
>> > it's
>> > useful for more than just CSS, but that doesn't bother me.
>>
>> Note that Dirk's the maintainer of that code, and he's planning to
>> rename the interface, I think to TransformMatrix.  That prefix isn't
>> good for point/rect/quad, though.
>
>
> Dirk and I preferred that the class is named CSSMatrix but the CSS WG didn't
> like it so wanted to rename it.
> If we're prefixing the other classes with 'DOM', maybe we should do it for
> Matrix as well.

I could put up a naming poll if you want.  It was pretty useful last time!

~TJ
Received on Thursday, 29 August 2013 03:02:26 UTC

This archive was generated by hypermail 2.4.0 : Friday, 25 March 2022 10:08:33 UTC