Re: [css-counter-styles] Name conflict in CSSCounterStyleRule IDL

On Fri, Sep 14, 2012 at 4:25 AM, Tab Atkins Jr. <>wrote:

> I've flattened the descriptors for @counter-style into the
> CSSCounterStyleRule interface, but that produces a naming conflict - I
> have a 'type' descriptor, but CSSRule also defines a 'type' attribute
> (for the type of the rule).
> Opinions on what the attribute corresponding to the 'type' descriptor
> should be named? Should I rename the descriptor itself to avoid
> collisions, so that I can maintain a 1-1 relationship between the
> descriptors and the IDL?

I had suggested counterType in an earlier thread for just this reason. It
still is 1-1, though it isn't the exact same name using the normal
de-hyphenation (etc) rules. If you don't want an exception here, I'd
suggest you rename the descriptor to counter-type.

Received on Friday, 14 September 2012 05:42:14 UTC