Replace document.elementFromPoint() and document.caretPositionFromPoint() by functions named like similar functions returning all elements under the given point

document.elementFromPoint() and document.caretPositionFromPoint() are
defined to use hit testing to return the uppermost element resp. a range
related to it at a specific viewport point[1].
My question is now, what to do when you want to get elements lying under it?
Therefore I suggest that these functions should be replaced by functions
returning all elements under that specific point sorted descending by their

Also their current names don't comply with the naming of similar functions
like document.getElementsByName().
So I'd say they should be renamed to document.getElementsFromPoint() and

For reference: I already mentioned these points in another thread[2][3].



Received on Monday, 29 October 2012 06:50:37 UTC