Re: [css3-flexbox] flex-pack distribute bikeshed

On Thu, Sep 15, 2011 at 11:11 PM, Alex Mogilevsky <alexmog@microsoft.com>wrote:

>  From: Tab Atkins Jr.
>  Sent: Thursday, September 15, 2011 2:48 PM
> 
>  distribute:
>  +---------------------------+
>  |button     button     input|
>  |button               button|
>  +---------------------------+
> 
>  I mean, neither one's very great, but the justify seems *really* bad
> here.  The distribute case
>  looks way better when the last line has more than two entries in it:
> 
>  justify:
>  +--------------------------------------------------------+
>  |button    button    button    button    button    button|
>  |button button button button                             |
>  +--------------------------------------------------------+
> 
>  distribute:
>  +--------------------------------------------------------+
>  |button    button    button    button    button    button|
>  |button           button          button           button|
>  +--------------------------------------------------------+
> 
>  I think justify is just *horrid* here.  Ideally you'd like it to look
> something like this:
> 
>  flexgrid:
>  +--------------------------------------------------------+
>  |button    button    button    button    button    button|
>  |button    button    button    button                    |
>  +--------------------------------------------------------+
> 
>  (We're debating behavior at this point, not naming.  We can use the
> 'distribute' behavior and
>  call it 'justify', or vice versa.)
>
> This thread was confusing for me from the start. I first thought it is just
> about the name, but then there is a functional difference, defined I am not
> sure where...
>
> Of the options mentioned the one marked "distribute" makes more sense (it
> seems we are generally in agreement on that). Whatever it ends up doing
> though, for me personally "justify" seems a more natural naming - what I
> would try if I don't quire remember the syntax.
>

Sounds good to me. The only change to the spec would be the rename.


> Alex
>

Received on Sunday, 18 September 2011 20:45:58 UTC