W3C home > Mailing lists > Public > www-style@w3.org > September 2009

Re: image-fit and image-position renamed?

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Tue, 22 Sep 2009 11:31:20 -0500
Message-ID: <dd0fbad0909220931k4dd9ceb3md7effbdb56b56dc3@mail.gmail.com>
To: Håkon Wium Lie <howcome@opera.com>
Cc: fantasai <fantasai.lists@inkedblade.net>, www-style@w3.org
On Tue, Sep 22, 2009 at 10:14 AM, Håkon Wium Lie <howcome@opera.com> wrote:
> fantasai scribed:
>  > image-fit and image-position
>  > ----------------------------
>  >
>  >    RESOLVED (TENTATIVE): Merge image-fit and image-position into single
>  >                         'fit' property
>  >    RATIONALE: 'image-fit' and 'image-position' are not appropriate names for
>  >               what SVG wants to use them for, and nobody had a better proposal.
> I don't think this is a good solution, the resulting property will be
> very complex considering all the values on 'image-fit' and
> 'image-position':
>  http://dev.w3.org/csswg/css3-page/#propdef-image-posn
>  http://dev.w3.org/csswg/css3-page/#propdef-image-fit

I don't know that I agree with this reasoning - image-fit is only a
single choice among four keywords, and image-position is just a
slightly simplified version of bg-position (which is strange, actually
- it should probably just reference bg-position directly so it can use
the full syntax).  Combining them wouldn't be that complex.

However, I agree that they shouldn't be merged.

> I suggest that we either (1) stick to the current "image" names but
> specify that this can apply to <video> as well, or that we (2) rename
> these to 'content-fit' and 'content-position'.
> My preference would be (2).

I agree.  (2) is my preferred solution as well.  It also seems to be
what SVGWG likes.

Received on Tuesday, 22 September 2009 16:32:17 UTC

This archive was generated by hypermail 2.4.0 : Monday, 23 January 2023 02:13:39 UTC