W3C home > Mailing lists > Public > www-jigsaw@w3.org > November to December 1997

Re: Extensions again

From: Christoph Begall <begall@nads.de>
Date: Fri, 21 Nov 1997 10:25:02 +0000
Message-ID: <3475617E.1D88DBFC@nads.de>
To: Jigsaw mailing list <www-jigsaw@w3.org>
Because I got stuck with everything I used a perfectly clean
installation of jigsaw. I tried to add my Extension again, and
it was not found again. (I did not make a new indexer but
instead added the Extension to default.) Then I found out, that
case (in)sensitivity was the problem. I run jigsaw under solaris,
jigadm-tool under windows 95. The first is started via telnet,
the second accesses jigsaw-root via SAMBA. This leads to the
strange behaviour that jHtml was not recognized by the indexer
as a new extension, but jhtml was perfectly fine. 

Now for me this is fine, as I know how to fix things, but there is
a genaral lack: I liked the administration from any computer that was
able to run a Browser and access the WWW. But formbased administration
seems to work now longer.

jigadm administration leads to the above mentioned problems.
Another lack is that I have to have file access to the root 

Yves Lafon wrote:
> On Tue, 18 Nov 1997, Christoph Begall wrote:
> > Hello,
> >
> > I'm sorry, but there seems to be a problem with indexer/extensions
> > in jigsaw beta1:
> > First I made a new indexer, because I wanted a special directory,
> > named special, where I put my Indexer (named specialInd) as indexer,
> > where all directories had the class MyDirectory and html was mapped
> > to SSIResource. The directory thing went fine, but the extension
> > was not recognized. So I used a new name for it (jHtml) and renamed
> > all my files. But they were not found by the server.
> > So I made one last attempt, because something could have gone wrong
> > with my MyDirectory: I put my jHtml extension to default-indexer
> > extensions. But even when I put the physical files in a totally new
> > directory, nothing happens.
> > Actually I don't know where to start.
> Hum... it seems strange...
> Do you have something like that:
> indexer name:
> MyIndexer
> indexclass: w3c.jigsaw.indexer.SampleResourceIndexer
> in Directories:
>   *default* with:
>      class (your class name)
> in Extensions:
>    jHtml with
>      class w3c.jigsaw.ssi.SSIResource
>      content-type: text/html
> Reindex your Directory (remove it using jigadm), create it again (normal
> resource add in jigadm) and set the indexer to MyIndexer.
> then access it with a browser to index the directory and the files, and
> it should be ok...
> If not, I am curious to see what is happening, as it works perfectly here...
Received on Friday, 21 November 1997 04:28:47 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 22:41:23 UTC