W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2015

Re: event handler name motivation

From: Bjoern Hoehrmann <derhoermi@gmx.net>
Date: Mon, 26 Jan 2015 02:19:12 +0100
To: Mark Volkmann <r.mark.volkmann@gmail.com>
Cc: "www-dom@w3.org" <www-dom@w3.org>
Message-ID: <725bca5n3r5ljoj5s273v0bcvg1o5hpo0l@hive.bjoern.hoehrmann.de>
* Mark Volkmann wrote:
>Does anyone know/remember what the motivation was for using event 
>handler function names like onreadystatechange (all lowercase) rather 
>than onReadyStateChange? I can't think of the another API that does 
>that. They seem harder to read when all lowercase. Of course there's no 
>way to change it now.

Long ago I made http://www.w3.org/wiki/List_of_events where you can see
that other naming schemes have been attempted, including `camelCase`,
`CamelCase`, `da-shes`, in addition to `alllowercase`, and without much
planning and coordination, and a lot of legacy, that's what we ended up
with. 
-- 
Björn Höhrmann · mailto:bjoern@hoehrmann.de · http://bjoern.hoehrmann.de
D-10243 Berlin · PGP Pub. KeyID: 0xA4357E78 · http://www.bjoernsworld.de
 Available for hire in Berlin (early 2015)  · http://www.websitedev.de/ 
Received on Monday, 26 January 2015 01:19:43 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:23 UTC