W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2015

event handler name motivation

From: Mark Volkmann <r.mark.volkmann@gmail.com>
Date: Sun, 25 Jan 2015 19:56:00 -0500
Message-Id: <CD62BB17-3C3D-47B1-94B8-1A8F537896BF@gmail.com>
To: "www-dom@w3.org" <www-dom@w3.org>
Does anyone know/remember what the motivation was for using event handler function names like onreadystatechange (all lowercase) rather than onReadyStateChange? I can't think of the another API that does that. They seem harder to read when all lowercase. Of course there's no way to change it now.

R. Mark Volkmann
Object Computing, Inc.
Received on Monday, 26 January 2015 00:56:27 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:23 UTC