Re: ISSUE-179: DOM Core uses INVALID_STATE_ERR (DOMException) where D3E uses DISPATCH_REQUEST_ERR (EventException)

On Fri, 29 Jul 2011 14:59:34 -0700, Jacob Rossi  
<> wrote:
> Per the working group's discussion in the 5/5/2011 teleconference, we  
> have rejected this issue. We find it useful to have a unique exception  
> name for this case. The more descriptive name provides more context for  
> the error at hand; making debugging easier. Additionally, not  
> overloading INVALID_STATE_ERROR is preferable for SEO of specs and other  
> documentation to help understand the error.

I do not think it makes sense to have EventException solely for this.  
Especially as INVALID_STATE_ERR matches the semantics perfectly fine. And  
if people want to find out why dispatchEvent fires an exception they can  
find out by searching for dispatchEvent. Given the way we have used  
exceptions throughout the web platform to date documentation would have to  
scope exceptions to methods anyway. We do not introduce new exceptions for  
one method generally.

Anne van Kesteren

Received on Friday, 29 July 2011 22:45:55 UTC