Re: minor bug in DOM Level 2 Traversal spec

>Since this appears to be Java code

Beware assumptions. We never stated the language, as far as I can tell, and
note that what Java calls getFirstChild() _is_ just called firstChild() in
the ECMAScript bindings, due to different local naming conventions.

I honestly dont't know whether this code would be acceptable ECMAScript
either -- I can read that language but haven't written it.

If not, there may be a case for fixing it so it's one or the other. Or
there may not be. This is only intended as pseudocode in any case, since
the DOM is language-independent. If the concept is clear, that may really
be all we need.

Joe Kesselman  / IBM Research

Received on Friday, 17 August 2001 10:18:46 UTC