Re: Crash when opening the Palette (Was: Black text on a black

> >> One can easily detect whether
> >> Amaya couldn't allocate the full set by opening the Color palette in 
> >> the Style menu. Each cell should have a specific color allocated. 
> >
> >Hmmm, Amaya crashes whenever I attempt this...
>   Well I tried to reproduce the bug, but didn't succeeded. On my Linux
> machines the palette opens properly, both with a 16 bit TrueColor display
> and with a standard 8 plane display. Could you give me more informations
> on :
>    - the client machine : Elf or a.out, wich version of XFree is installed
>      a result of ldd on thot/bin/LINUX-ELF/amayamain (or 
>      thot/bin/LINUX/amayamain on an a.out system) would be useful.
>    - The Xserver machine if using a remote display, e.g. on a Sun. In this
>      case the result of a xdpyinfo could help too.

It crashes on my Slackware 2.0 box, which is an ELF based system
with a 1.2.13 kernel.

$ ldd bin/LINUX-ELF/amayamain => /usr/X11R6/lib/ => /usr/X11R6/lib/ => /usr/X11R6/lib/ => /usr/X11R6/lib/ => /usr/X11R6/lib/ => /lib/ => /lib/

$ /usr/bin/X11/X -showconfig

XFree86 Version 3.1.2 / X Window System
(protocol Version 11, revision 0, vendor release 6000)
Operating System: Linux 
Configured drivers:
  S3: accelerated server for S3 graphics adaptors (Patchlevel 0)
      mmio_928, s3_generic

It crashes when displaying on the local host.  Just now I tried
setting the DISPLAY to a remote machine and it was able to display
the pallette without crashing.  I also tried 3 different window
on the local system.  It crashed in every case.  Apart from Amaya
I don't have any problems with this Xserver.  It appears to crash
after it has displayed the two lines of text at the top of the
pallette window, but before it has displayed any of the colors.

Without source I can't help debug this problem any futher.


Received on Thursday, 1 August 1996 21:45:05 UTC