Role Taxonomy - some comments

Some random comments on the spec version

1. The RDF schema has a few typos. In order to make it validate, you need  
to change some instances of rdfs:sub propertyOf to rdfs:subPropertyOf and  
make sure that each of the xmlns declarations and the xml base declaration  
has a space before it in the first RDF element.

2. Rather than assigning a numeric importance to each heading level, why  
not just define them in terms of being more or less important than  
another, with a transitive property? This is likely to be more accurate,  
and allows for extensibility since it is relatively easy to insert  
something in a list.

3. Having a slider and a dial for the same control seems counter-intuitive  
to me, since the goal is to represent the functionality (essentially  
continuous selection on a range, or is it in fact only discrete values?)  
not the implementation's presentation of the control.

4. The example in 3 would be better as

<rdf:Description rdf:ID="Checkbox">
   <rdf:type rdf:resource="#Select"/>
   <baseConcept rdf:resource="" />
   <supportedState rdf:resource=""  



Charles McCathieNevile     +61 409 134 136     Opera Software                     |

Received on Tuesday, 6 December 2005 05:33:26 UTC