Re: Proposal for subordinate source elements


Murray Maloney wrote:
> I was hoping for a lively discussion, but any discussion at all would 
> do. :-)

My thoughts aren't organised, but I thought I should get them down.

(1) I like that a nested-element syntax does away with long attribute 
names like "from-step" and "from-source".

(2) I like that a nested-element syntax gives a neat way of specifying 
the input to a for-each/viewport/choose without having to name a port.

(3) I like the fact that nested elements give us an easy way of building 
a sequence for a port (and even that these sequences might come from 
different sources).

(4) I worry that a nested-element syntax is pretty verbose, but perhaps 
<p:internal> could be omitted in the default case (where you reference 
the only output of the previous step).

(5) I don't like Murray's names at all. I'd prefer something like 
<p:ref> instead of <p:internal>; <p:load> for <p:external>; and (like 
Alex) <p:document> for the "here" document.

(6) I'm ambivalent about whether we should have one kind of nested 
element with three possible sets of attributes, or three different kinds 
of nested elements. The latter is easier to validate usefully with DTDs 
and XML Schema.

I think that comes out as a vote for a nested-element syntax but with 
different names to the ones that Murray proposed.

While I'm at it, I wanted to support Richard's proposal to change the 
'port' attribute on <p:input> and <p:output> to 'name'. I'd vote against 
changing <p:otherwise> to <p:else> (it might line up better, but it will 
confuse XSLT users).


Jeni Tennison

Received on Thursday, 7 December 2006 14:09:11 UTC