W3C home > Mailing lists > Public > whatwg@whatwg.org > March 2012

[whatwg] translate attribute conflicts with http://www.winktoolkit.org/documentation/symbols/HTMLElement.html#translate

From: Ian Hickson <ian@hixie.ch>
Date: Mon, 26 Mar 2012 22:17:03 +0000 (UTC)
Message-ID: <Pine.LNX.4.64.1203262214440.22654@ps20323.dreamhostps.com>
On Mon, 26 Mar 2012, Adam Barth wrote:
> WebKit recently implemented
> http://www.whatwg.org/specs/web-apps/current-work/#attr-translate, but
> that caused us to break orange.fr on mobile:
> https://bugs.webkit.org/show_bug.cgi?id=82246
> The problem is that
> http://www.winktoolkit.org/documentation/symbols/HTMLElement.html#translate
> has a the following code:
> if (wink.isUndefined(HTMLElement.prototype.translate))
>     HTMLElement.prototype.translate = HTMLElement.prototype.winkTranslate;
> The web site expects HTMLElement.prototype.translate to be Wink's
> translate function rather than the HTML translate attribute.
> Would it make sense to change the name of the translate attribute to 
> avoid this conflict?  Should we try to evangalize the Wink Toolkit to 
> change their code and everyone who uses Wink to update to the fixed 
> version?

How widely used is it? (In particular, how widely used is .translate() 
rather than .winkTranslate()?)

I don't mind changing the name, but it's unclear that there's a better 
name out there. It would be unfortunate to have to reserve the use of a 
name as generic as "translate" for a particular library.

In any case we should definitely ask Wink to avoid unprefixed names. 
That's asking for trouble.

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'
Received on Monday, 26 March 2012 15:17:03 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:59:40 UTC