Re: I have created a PR for RtpSender.getCapabilities and RtpReceiver.getCapabilities

On 18 Jul 2015 9:20 am, "Roman Shpount" <> wrote:
> On Fri, Jul 17, 2015 at 6:58 PM, Peter Thatcher <>
>> 1.  Is there enough consensus from the WG to add this?  I'm in favor of
it :).
> I am for it as well.
>> 2.  Should getCapabilities return a Promise?  I think it doesn't need to
be, so I made it not return a Promise.
> I do not think this needs to be a promise. In most cases these things are
known by implementation in advance and should not require a lot of time or
resources to compute.
>> 3.  Should be a MIME type ("video/vp8") or just a name
("vp8")?  If a MIME type, should it be code.mimeType instead of
Or should we have both and codec.mimeType.   I've made it with MIME type here, which matches ORTC.  But I'm currently
thinking I'd prefer with a name instead.  I'd also be happy with
having both and codec.mimeType.
> I would think that having separate and codec.mimeType would be
the best option. Based on there are
cases when there is a mismatch between the name and the mime type, such
as "" and "video/vnd-vivo". I hope no will ever need any of those
codecs, but theoretically it is possible.

One piece of warning: duplicate information like this can lead to
conflicting information orifices in the two fields. I would prefer to just
use mime types as defined by IANA: note
that these are the rtp mime types, not the file mime types, which is more
appropriate for WebRTC imho.


Received on Friday, 17 July 2015 23:33:43 UTC