W3C home > Mailing lists > Public > public-webrtc@w3.org > December 2014

Renaming RTCIceTransports to RTCIceTransportPolicy

From: Peter Thatcher <pthatcher@google.com>
Date: Mon, 29 Dec 2014 15:52:10 -0800
Message-ID: <CAJrXDUF+QPBmmXyNLqEuRhbnP8y=YVtfPqbFoEqNqr5q+SMdUw@mail.gmail.com>
To: "public-webrtc@w3.org" <public-webrtc@w3.org>
At TPAC 2014, we decided to rename "RTCIceTransports" to
"RTCIceTransportPolicy", but we never discussed it on the list or made a
tracking bug.  I have made a PR to do so:


However, I had two questions for the list:

1.  Should we rename RTCConfiguration.iceTransports to
RTCConfiguration.iceTransportPolicy as well?  I think so, so I that's what
I did in the PR.

2.  Should we change the type of RTCConfiguration.iceTransportPolicy from
RTCIceTransportPolicy to DOMString?  During the discussion of
RTCBundlePolicy,  Jan-Ivar suggested that was a good idea because it made
it easier to add values to the enum in the future.  I don't care much
either way, but I'd like RTCTransportPolicy and RTCBundlePolicy to be
consistent.  We should either make RTCIceTransportPolicy a DOMString or
make RTCConfiguration.bundlePolicy an RTCBundlePolicy.  Which shall it be?
Received on Monday, 29 December 2014 23:53:18 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 15:19:42 UTC