Re: [mediacapture-region] Is CropTarget name too generic? (#18)

I am not sure looking at it from a web developer inspecting each property is the right angle here.
A better angle might be to look at what might come next.
Basically, either we decide to name this object according its current use (a reference used for cropping) or according what it represents (an element reference).

Either we augment CropTarget to expose more of Elements (say its name) and it is better to have a name that clarifies that this is tied to an element. It could for instance be reused in other APIs (dom element capture track can be exposed to workers and has an API to get its element for instance).

Or we might augment CropTarget API to allow cropping for various sources using the same CropTarget.
For instance, if we want in the future to allow cropping of a screen or a window, would we reuse CropTarget or something else?
My understanding from past discussions with you is that we would not reuse CropTarget here, hence why a name focused on what the object is (ElementReference, ElementProxy...) seems more appropriate at the moment.

Of course, who knows the future. But in any case, these are the kind of discussion I'd like to have to validate the name selection.

GitHub Notification of comment by youennf
Please view or discuss this issue at using your GitHub account

Sent via github-notify-ml as configured in

Received on Monday, 21 March 2022 14:37:46 UTC