W3C home > Mailing lists > Public > public-webpayments@w3.org > January 2014

Fwd: Re: Finalizing Reservation schemas for schema.org

From: ☮ elf Pavlik ☮ <perpetual-tripper@wwelves.org>
Date: Tue, 28 Jan 2014 16:48:45 +0100
Message-ID: <52E7D15D.2030900@wwelves.org>
To: Web Payments CG <public-webpayments@w3.org>
CC: Martin Hepp <martin.hepp@ebusiness-unibw.org>, Dan Brickley <danbri@google.com>
I find this discussion having relevance to work here in Web Paymetns CG. 
Very likely people may want to use Web Payments for Transactions related 
to all those Reservations!

I would really like that people who use Schema.org can very easily use 
Web Payments as well :)

-------- Original Message --------
Subject: Re: Finalizing Reservation schemas for schema.org
Resent-Date: Tue, 28 Jan 2014 08:35:25 +0000
Resent-From: public-vocabs@w3.org
Date: Tue, 28 Jan 2014 09:34:29 +0100
From: Martin Hepp <martin.hepp@ebusiness-unibw.org>
To: Vicki Tardif Holland <vtardif@google.com>
CC: ☮ elf Pavlik ☮ <perpetual-tripper@wwelves.org>, PublicVocabs 


> 2. Price information
> If price and priceCurreny are only used to indicated what was charged for the ticket (in the sense of a payment transaction), it can stay as it is.
> But if the intended use is also to indicate offers to tickets, the new http://schema.org/priceSpecification property should be used.
> This done properly will allow for very powerful use-cases like
> "An offer for a family ticket for the Bryan Adams concert at the Verizon Wireless Amphitheatre for 1-2 adults and 0-2 kids aged 0-6 years"
> with very little additional elements. See http://www.heppnetz.de/ontologies/tio/ns#family_example.
> Conclusion: If the properties are only used for transactions, it can stay as it is.
> <vth> The intention is to record what the person paid for the ticket in 'price'. I assume an offer price would be part of a http://schema.org/Offer. Perhaps the price property should be changed to 'pricePaid' or similar to clarify the difference.
> </vth>

Yes, pricePaid would be perfectly fine, and then maybe change the range 
from Number to Number OR PriceSpecification, so people could use the 
more advanced modeling of that type (see also the ongoing discussion on 
tax information; we would then not need to duplicate efforts for 
modeling tax information).
Received on Tuesday, 28 January 2014 15:48:26 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:07:27 UTC