Boris Zbarsky
bugzilla@jessica.w3.org
- [Bug 27771] Should HKDF' s derive bits operation throw OperationError if length is null? (Tuesday, 24 May)
- [Bug 29438] JSON.stringify as invoked by wrapKey can have side-effects depending on what you pass it (Tuesday, 24 May)
- [Bug 29437] Parsing a JWK can have side-effects if not done very carefully (Tuesday, 24 May)
- [Bug 29569] summary!!!! (Tuesday, 24 May)
- [Bug 29545] ECDSA 'alg' names for JWK: ES512 vs ES521 (Tuesday, 24 May)
- [Bug 29539] Invalid algorithm OID for ECDH (Tuesday, 24 May)
- [Bug 29514] Need to define which globals objects created by this spec are associated with (Tuesday, 24 May)
- [Bug 29359] Make the "exceptions" section clearer (Tuesday, 24 May)
- [Bug 29139] Allow specifying numbers in place of BigInteger? (Tuesday, 24 May)
- [Bug 29005] Add support for secp256k1 curve (Tuesday, 24 May)
- [Bug 28551] TODO: create example utility function that converts text -> ArrayBufferView (Tuesday, 24 May)
- [Bug 27946] getRandomValues should mention Uint8ClampedArray (Tuesday, 24 May)
- [Bug 27942] Expose GlobalCrypto in Worker (Tuesday, 24 May)
- [Bug 27816] IANA considerations review for definition of algorithms (Tuesday, 24 May)
- [Bug 27815] IANA Considerations for "ext" (Tuesday, 24 May)
- [Bug 27814] Section A.2 - the usage mapping of "enc" is incorrect (Tuesday, 24 May)
- [Bug 27774] The KDFs either shouldn't allow importing extractable keys, or should support exportKey() (Tuesday, 24 May)
- [Bug 27783] Incompatible specification for how usages is enforced for ECDH (Tuesday, 24 May)
- [Bug 27774] The KDFs either shouldn't allow importing extractable keys, or should support exportKey() (Tuesday, 24 May)
- [Bug 27773] Clarification of unwrapKey method parameters (Tuesday, 24 May)
- [Bug 27772] Typo: "withe" -> "with" (Tuesday, 24 May)
- [Bug 27771] Should HKDF' s derive bits operation throw OperationError if length is null? (Tuesday, 24 May)
- [Bug 27755] Using the Subtle Crypto Interface with Streams (Tuesday, 24 May)
- [Bug 27717] Require RSA key import to validate the key parameters (Tuesday, 24 May)
- [Bug 27702] KeyAlgorithm misses semicolon (Tuesday, 24 May)
- [Bug 27689] Is PBKDF2's generateKey() UI step worthwhile? (Tuesday, 24 May)
- [Bug 27685] References link to PKCS3 is broken (Tuesday, 24 May)
- [Bug 27622] Typo: "Import key" -> "importKey" in section 34.2, 35.2 (Tuesday, 24 May)
- [Bug 27621] Inconsistent name for getLength operation (Tuesday, 24 May)
- [Bug 27617] Remove Section 4.3 "Operations" from the spec (Tuesday, 24 May)
- [Bug 27603] verify() can fail either by returning flase or rejecting with an error, inconsistent which is used (Tuesday, 24 May)
- [Bug 27602] ECDSA' s Sign operation is not explicit about how r and s are concatenated ( padding) (Tuesday, 24 May)
- [Bug 27601] Inconsistent enforcement of JWK's "use" versus "key_ops" during public key import (Tuesday, 24 May)
- [Bug 27600] Inconsistent formatting (indentation) of WebIDL blocks (Tuesday, 24 May)
- [Bug 27598] Clarification: Can NotSupportedError be thrown in places where the spec uses an OperationError ? (Tuesday, 24 May)
- [Bug 27591] Must the reflected "publicExponent" for generated RSA keys exactly match input? (Tuesday, 24 May)
- [Bug 27588] Typo "myst" --> "must" (Tuesday, 24 May)
- [Bug 27587] Section 19, Algorithm Overview, does not mention verify() or deriveBits() methods (Tuesday, 24 May)
- [Bug 27586] Incorrect link to "decrypt" (Tuesday, 24 May)
- [Bug 27585] Extraneous "the" in description of wrapKey (Tuesday, 24 May)
- [Bug 27584] Wording: "subtlecrypto methods" --> "SubtleCrypto methods" (Tuesday, 24 May)
- [Bug 27581] Wording: Algorithm names must be unique when compared case-insensitively (Monday, 23 May)
- [Bug 27580] "case sensitive" --> "case insensitive" (Monday, 23 May)
- [Bug 27579] Inconsistent spelling of "[[ This Document]]" (Monday, 23 May)
- [Bug 27578] Outdated reference to JWK spec (Monday, 23 May)
- [Bug 27577] Remove unreferenced exceptions (Monday, 23 May)
- [Bug 27564] Must conforming implementations match the order of errors? (Monday, 23 May)
- [Bug 27563] Consistency: "W3C WebCrypto Working Group" vs " W3C WebCrypto Working Group (Monday, 23 May)
- [Bug 27562] Odd wording of section " 2.7. Javascript Object Signing and Encryption (JOSE)" (Monday, 23 May)
- [Bug 27561] Reword RTCWEB --> WebRTC? (Monday, 23 May)
- [Bug 27560] Remove reference to "events" in the introduction (Monday, 23 May)
- [Bug 27506] Inconsistent error for AES-CTR's "get key length" operation (Monday, 23 May)
- [Bug 27486] RsaHashedImportParams does not extend Algorithm (Monday, 23 May)
- [Bug 27485] Spelling error "definines" (Monday, 23 May)
- [Bug 27474] Editorial Note from Appendix A: Additional JWK-> Algorithm conversions (Monday, 23 May)
- [Bug 27473] Explicit salts for the algorithm formerly known as HKDF (Monday, 23 May)
- [Bug 27472] RSAHashedKeyGenParams vs. Dictionary Fields Editorial Note (Monday, 23 May)
- [Bug 27471] Provide even more informative text over key wrapping? (Monday, 23 May)
- [Bug 27465] Update references from X9.63 to SECG (Monday, 23 May)
- [Bug 27449] Algorithm normalization references "KeyAlgorithm" rather than "Algorithm" (Monday, 23 May)
- [Bug 27448] HmacImportParams having a non-required hash is inconsistent with other algorithms (Monday, 23 May)
- [Bug 27447] Inconsistent use of "raw" format for EC keys (Monday, 23 May)
- [Bug 27439] Inconsistent naming of the "Get key length" operation (Monday, 23 May)
- [Bug 27438] Inconsistent result type for "Result" column of " Get Key length" operation (Monday, 23 May)
- [Bug 27425] HKDF-CTR needs a new name (Monday, 23 May)
- [Bug 27404] Should check the publicKey's algorithm.name for ECDH' s deriveBits()? (Monday, 23 May)
- [Bug 27403] Should PBKDF2 be allowed on non-multiple of 8 lengths for consistency? (Monday, 23 May)
- [Bug 27402] Specify the behavior when returning an octet string with a particular _bit_ length (Monday, 23 May)
- [Bug 27374] Please remove older Editorial Notes from spec (Monday, 23 May)
- [Bug 27305] "Perform type mapping as specified in [WEBIDL] for data." (Monday, 23 May)
- [Bug 27298] Reference IDL rather than define a "clone the data" algorithm (Monday, 23 May)
- [Bug 27255] Inconsistent handling of SPKI / PKCS#8 data between implementations (Monday, 23 May)
- [Bug 25972] Please require a secure origin (Monday, 23 May)
- [Bug 27425] HKDF-CTR needs a new name (Monday, 23 May)
- [Bug 27255] Inconsistent handling of SPKI / PKCS#8 data between implementations (Monday, 23 May)
- [Bug 27404] Should check the publicKey's algorithm.name for ECDH' s deriveBits()? (Monday, 23 May)
- [Bug 29545] ECDSA 'alg' names for JWK: ES512 vs ES521 (Monday, 23 May)
Charles Engelke
Eric Roman
GALINDO Virginie
Harry Halpin
Jim Schaad
Mark Watson
Ryan Hurst
Ryan Sleevi
Tim Taubert
Web Cryptography Working Group Issue Tracker
Wendy Seltzer
Last message date: Wednesday, 25 May 2016 22:55:37 UTC