RE: [webcomponents]: Naming the Baby

Hello all,

What about something like Web Imports w/ rel=import .  Basically it's a means to import a building block/component.

I think on the mailing list there was the suggestion of package.  Seems reasonable too.  Others that are in the same vein with equally generic issues include block and widget.  Web Elements might also work, but the use of "element" may be a little overloaded.


From: Dimitri Glazkov []
Sent: Monday, March 25, 2013 3:03 PM
To: public-webapps
Cc: Elliott Sprehn; Angelina Fabbro; Brian Kardell; Steve Orvell;;; Dominic Cooney
Subject: [webcomponents]: Naming the Baby

Hello folks!

It seems that we've had a bit of informal feedback on the "Web
Components" as the name for the <link rel=component> spec (cc'd some
of the "feedbackers").

So... these malcontents are suggesting that "Web Components" is more a
of a general name for all the cool things we're inventing, and <link
rel=component> should be called something more specific, having to do
with enabling modularity and facilitating component dependency
management that it actually does.

I recognize the problem, but I don't have a good name. And I want to
keep moving forward. So let's come up with a good one soon? As
outlined in


1) must reflect the intent and convey the meaning.
2) link type and name of the spec must match.
3) no biting.


Received on Tuesday, 26 March 2013 09:05:36 UTC