Re: Overlap between StreamReader and FileReader

On Sat, May 18, 2013 at 1:38 PM, Jonas Sicking <jonas@sicking.cc> wrote:

> For File reading I would now instead do something like
>
> partial interface Blob {
>   AbortableProgressFuture<ArrayBuffer> readBinary(BlobReadParams);
>   AbortableProgressFuture<DOMString> readText(BlobReadTextParams);
>   Stream readStream(BlobReadParams);
>

I'd name it "asStream". readStream operation here isn't intended to do any
"read", i.e. moving data between buffers, (like ArrayBufferView for
ArrayBuffer) right?

Or it's gonna clone the Blob's contents and wrap with the Stream interface
as we cannot "discard" contents of a Blob and it'll be inconsistent with
the semantics (implication?) we're going to give to the Stream interface?

Received on Saturday, 18 May 2013 07:49:42 UTC