W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2010

Re: [XHR2] ArrayBuffer integration

From: Anne van Kesteren <annevk@opera.com>
Date: Thu, 23 Sep 2010 11:42:07 +0200
To: "Julian Reschke" <julian.reschke@gmx.de>, "Kenneth Russell" <kbr@google.com>
Cc: "Chris Marrin" <cmarrin@apple.com>, "Web Applications Working Group WG" <public-webapps@w3.org>, "Vladimir Vukicevic" <vladimir@mozilla.com>
Message-ID: <op.vjhbwhpx64w2qv@anne-van-kesterens-macbook-pro.local>
On Wed, 08 Sep 2010 19:55:33 +0200, Kenneth Russell <kbr@google.com> wrote:
> Mozilla's experimental name is "mozResponseArrayBuffer", so perhaps to
> avoid collisions the spec could call it responseArrayBuffer.

While I do not think there would be collision (at least not in ECMAScript,  
which is what we are designing for) naming it responseArrayBuffer is fine  
with me. And also now done that way in the draft. Still need to get a  
saner reference to the ArrayBuffer specification than  
though. :-)


(You can also do send(ArrayBuffer) obviously. I personally think  
supporting this for both BlobBuilder and send() makes sense. That way  
Blob/File etc. work too.)

Anne van Kesteren
Received on Thursday, 23 September 2010 09:42:53 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:11 UTC