W3C home > Mailing lists > Public > public-webapps@w3.org > July to September 2010

Re: [IndexedDB] IDBCursor.update for cursors returned from IDBIndex.openCursor

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 20 Sep 2010 14:38:20 -0700
Message-ID: <AANLkTin70H6zAdMwceY_cLw_vAjQXuvW-27CHj_u52g0@mail.gmail.com>
To: Jeremy Orlow <jorlow@chromium.org>
Cc: public-webapps WG <public-webapps@w3.org>
On Fri, Sep 17, 2010 at 3:14 PM, Jonas Sicking <jonas@sicking.cc> wrote:
>> Given that the key-returning versions of these functions are just
>> optimizations, at the very least, we should change the names though:
>> get->getKey (or maybe getPrimaryKey?)
>> openCursor->openKeyCursor (or maybe openPrimaryKeyCursor?)
>> getObject->get
>> openObjectCursor->openCursor
> I can't say that I feel strongly on the naming issue. Will ask around
> here to see how people feel.

This sounds like a workable solution. And also make IDBCursor.update
and IDBCursor.delete throw an exception if called on a key-cursor.

/ Jonas
Received on Monday, 20 September 2010 21:39:15 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:13:11 UTC