Re: Interface names in IndexedDB (and WebSQLDatabase)

In general, sounds good to me.  Note that there already is an
IndexedDatabase interface in your spec though.

I'd also suggest renaming at least the following:

ObjectStore
KeyRange
Environment
DatabaseError

At which point, there's not too many interfaces left without the IDB prefix
(mostly synchronous variants of these interfaces) so maybe we should just
prefix everything?

Thanks!
J

On Fri, Jan 22, 2010 at 8:16 AM, Nikunj Mehta <nikunj@o-micron.com> wrote:

>
> On Jan 22, 2010, at 12:01 AM, Jeremy Orlow wrote:
>
>  The interface names in IndexedDB (and to an extent, WebSQLDatabase) are
>> very generic.  Surprisingly, the specs only collide via the "Database"
>> interface (which is why I bring this up), but I'm concerned that names like
>> Cursor, Transaction, and Index (from IndexedDB) are so generic that they're
>> bound to conflict with other specs down the road.
>>
>> Note that all but 5 interfaces in the WebSQLDatabase spec are prefixed
>> with SQL (for example, SQLTransaction) which helps a lot.  It seems as
>> though the remaining could also be prefixed by SQL to solve the problem.
>>
>
> That will help.
>
>
>
>> I'm wondering if the majority of the IndexedDB interfaces should also have
>> some prefix (like IDB?) as well since many of its terms are quite generic.
>>
>
> I am fine with the following renaming:
>
> Database -> IndexedDatabase
> Cursor -> IDBCursor
> Transaction -> IDBTransaction
> Index -> IDBIndex
>
> Nikunj
>

Received on Friday, 22 January 2010 17:54:01 UTC