Re: [widgets] [access] Naming Conflict: <access> Element

The access element in XHTML Access Module [1] is not a key navigation 
element - it is a method for defining an abstract mapping from events to 
event handlers[2].  One such event might be a key press.  The XHTML 
Access Module has been under development for ages, and that name was 
specifically chosen by the PFWG.  I personally would be loathe to 
attempt to change it at this point - in particular since it is 
specifically mentioned in the XHTML 2 Working Group charter [3].


Doug Schepers wrote:
> Hi, WebApps WG and XHTML2 WG-
> There is a potential conflict between the <access> element defined in
> the Widgets 1.0: Packaging and Configuration specification [1] and the
> <access> element defined in the XHTML Access Module specification [2]
> (most recent draft also available [3]).
> It may be that both are never used in the same document; <widget:access>
> is intended for use in a configuration document, while <access:access>
> is intended for (X)HTML/SVG documents.  However, both elements are
> rather loosely named, and not immediately clear in intent.
> I propose that both specs change the name of their element.  A better
> name for Widgets might be <securityModel> or something, and for the
> Access spec, a better name might be <keyNav>.
> Thoughts?
> [1]
> [2]
> [3]
> Regards-
> -Doug Schepers
> W3C Team Contact, SVG and WebApps WGs

Shane P. McCarron                          Phone: +1 763 786-8160 x120
Managing Director                            Fax: +1 763 786-8180
ApTest Minnesota                            Inet:

Received on Friday, 20 February 2009 02:19:48 UTC