[widgets] [access] Naming Conflict: <access> Element

Hi, WebApps WG and XHTML2 WG-

There is a potential conflict between the <access> element defined in
the Widgets 1.0: Packaging and Configuration specification [1] and the
<access> element defined in the XHTML Access Module specification [2]
(most recent draft also available [3]).

It may be that both are never used in the same document; <widget:access>
is intended for use in a configuration document, while <access:access>
is intended for (X)HTML/SVG documents.  However, both elements are
rather loosely named, and not immediately clear in intent.

I propose that both specs change the name of their element.  A better
name for Widgets might be <securityModel> or something, and for the
Access spec, a better name might be <keyNav>.


[1] http://www.w3.org/TR/widgets/#the-access-element
[2] http://www.w3.org/TR/xhtml-access/#sec_3.1.
[3] http://www.w3.org/MarkUp/2008/ED-xhtml-access-20081023/

-Doug Schepers
W3C Team Contact, SVG and WebApps WGs

Received on Friday, 20 February 2009 01:44:53 UTC