Re: [widgets] [access] Naming Conflict: <access> Element

HI Doug,
On Fri, Feb 20, 2009 at 2:44 AM, Doug Schepers <> wrote:
> Hi, WebApps WG and XHTML2 WG-
> There is a potential conflict between the <access> element defined in
> the Widgets 1.0: Packaging and Configuration specification [1] and the
> <access> element defined in the XHTML Access Module specification [2]
> (most recent draft also available [3]).

I have added your concerns as an issue into the tracker [4]. We will
be discussing this issue at our F2F next week and will report back
with the WebApps  WG's position.

> It may be that both are never used in the same document; <widget:access>
> is intended for use in a configuration document, while <access:access>
> is intended for (X)HTML/SVG documents.  However, both elements are
> rather loosely named, and not immediately clear in intent.

There is a significant chance that they will be used together in the future.

> I propose that both specs change the name of their element.  A better
> name for Widgets might be <securityModel> or something, and for the
> Access spec, a better name might be <keyNav>.
> Thoughts?

Personally, I'm pretty happy with the way our element is named but if
you think that the semantics as specified are ambiguous, I will make
sure to clarify them. You are correct, however, to say that our
element is mostly to do with security/access-control, so
<security[Model]> is certainly a candidate if we are going to change
the name. Having said that, I'm also happy to rely on namespaces for
the distinction between the two.

Kind regards,

> [1]
> [2]
> [3]

Marcos Caceres

Received on Friday, 20 February 2009 07:13:10 UTC