- From: Cameron McCormack <cam@mcc.id.au>
- Date: Mon, 24 Nov 2008 14:25:39 +1100
- To: public-webapps@w3.org
Maciej Stachowiak: > > I think [NativeObject] should be renamed to [Callback]. It is meant to > > be used for callback objects that have a single designated callback > > method, right? Cameron McCormack: > Not only a single callback method, perhaps multiple. But yes, it’s > pretty much for callbacks. [Callback] looks nicer than [NativeObject], > so I think that’s a reasonable change. I’ve now renamed [NativeObject] to [Callback]. > > I see, I misunderstood what [Variadic] does. I think [Optional] would be > > a useful addition for functions that have a fixed number of optional > > arguments. Unless Web IDL has some way to represent that which I missed. … > [Optional] could be defined such that: > > interface A { > void f(in long w, [Optional] in long x, in long y, [Optional] int long z); > }; > > is equivalent to: > > interface A { > void f(in long w); > void f(in long w, in long x, in long y); > void f(in long w, in long x, in long y, in long z); > }; I’ve added [Optional] to do exactly the above. Thanks, Cameron -- Cameron McCormack ≝ http://mcc.id.au/
Received on Monday, 24 November 2008 03:26:31 UTC