W3C home > Mailing lists > Public > public-vocabs@w3.org > May 2013

RE: Activity Proposal Review

From: Yaar Schnitman <yaar@google.com>
Date: Thu, 23 May 2013 15:26:06 -0700
Message-ID: <CA+KV223D2W-A6T+Jks7BwvoxDteny3pCPVVABMCSpg-GAWmVzA@mail.gmail.com>
To: public-vocabs@w3.org, Jean-Pierre <evain@ebu.ch>, "kcoyle@kcoyle.net" <kcoyle@kcoyle.net>, James M Snell <jasnell@gmail.com>
James, Karen, Evain,

I think that renaming Action.performedBy to Action.actor are ok. Even
though Event.actor is currently defined to be an actor in a theater show,
Action does not inherit from Event, so .actor can have a new meaning. If
Action ends up extending Event, like some have suggested, its still ok that
the property's semantic is made more strict. Alternatively, Event.actor
should probably move down to the TheaterEvent type.

Received on Thursday, 23 May 2013 22:26:59 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:29:27 UTC