W3C home > Mailing lists > Public > public-secondscreen@w3.org > August 2015

Re: Renaming 'join' to 'reconnect'

From: Anton Vayvod <avayvod@google.com>
Date: Mon, 24 Aug 2015 21:20:36 +0100
Message-ID: <CAOjek6qAdCeXQrVzy-VXYGz3NbRPEx_L4Yz8wtRkM05vWZv3hQ@mail.gmail.com>
To: Jonas Sicking <jonas@sicking.cc>
Cc: "mark a. foltz" <mfoltz@google.com>, "public-secondscreen@w3.org" <public-secondscreen@w3.org>
On Mon, Aug 10, 2015 at 11:00 PM, Jonas Sicking <jonas@sicking.cc> wrote:

> On Mon, Aug 10, 2015 at 1:56 PM, mark a. foltz <mfoltz@google.com> wrote:
> >> It might be nice to make this more clear in the naming of the API.
> >> Maybe by renaming 'join' to 'reconnect' or 'resume' or some such?
> >
> >
> > I agree that join is not the best name.  Perhaps connect() covers use
> cases
> > #1-#3: since you can connect an additional controller, or reconnect after
> > navigation or restart.
>

I filed https://github.com/w3c/presentation-api/issues/170 to track the
renaming of join() to connect().


>
> I think 'start()' vs. 'connect()' doesn't make their difference
> entirely clear either. But I can certainly live with it and I agree
> it's an improvement.
>

create() as in create a new connection vs. reusing an existing one when
using connect()?

>
> / Jonas
>
>
Received on Monday, 24 August 2015 20:21:29 UTC

This archive was generated by hypermail 2.3.1 : Monday, 24 August 2015 20:21:30 UTC