W3C home > Mailing lists > Public > public-secondscreen@w3.org > August 2015

Re: Renaming 'join' to 'reconnect'

From: Jonas Sicking <jonas@sicking.cc>
Date: Mon, 10 Aug 2015 15:00:02 -0700
Message-ID: <CA+c2ei_ssXZy3SZKRYiRkQv66NO+PTnXFj11qO3Ov4fiy537rA@mail.gmail.com>
To: "mark a. foltz" <mfoltz@google.com>
Cc: "public-secondscreen@w3.org" <public-secondscreen@w3.org>
On Mon, Aug 10, 2015 at 1:56 PM, mark a. foltz <mfoltz@google.com> wrote:
>> It might be nice to make this more clear in the naming of the API.
>> Maybe by renaming 'join' to 'reconnect' or 'resume' or some such?
>
>
> I agree that join is not the best name.  Perhaps connect() covers use cases
> #1-#3: since you can connect an additional controller, or reconnect after
> navigation or restart.

I think 'start()' vs. 'connect()' doesn't make their difference
entirely clear either. But I can certainly live with it and I agree
it's an improvement.

/ Jonas
Received on Monday, 10 August 2015 22:00:59 UTC

This archive was generated by hypermail 2.3.1 : Monday, 10 August 2015 22:01:00 UTC