W3C home > Mailing lists > Public > public-sdw-wg@w3.org > February 2017

Re: Proposed solution to Issue-108 - Naming issues with observedBy

From: Maxime Lefrançois <maxime.lefrancois@emse.fr>
Date: Tue, 21 Feb 2017 11:38:10 +0000
Message-ID: <CALsPASXOXQrCY_Fy6nRMfX4r=7SSmJ1ocYE7QQhJ9ARmxBD=rw@mail.gmail.com>
To: Simon.Cox@csiro.au, armin.haller@anu.edu.au, janowicz@ucsb.edu, public-sdw-wg@w3.org
OK, then about ISSUE-108,

+1 for:
"oldssn:observedBy will be equivalent to the inverse of
sosa;madeObservation, i.e.,
 (a) sosa:observationMadeBy, or
 (b) sosa:madeBySensor"

I have a slight preference for (a) though. Will add that as an option to
the wiki.

Kind regards,
Maxime

Le mar. 21 févr. 2017 à 01:56, <Simon.Cox@csiro.au> a écrit :

> Yes –
>
>
>
> Did not intend to trigger that discussion prematurely, merely point out
> that external alignments that are already planned might take care of it. So
> we could put aside the issue of generalization for now.
>
>
>
> *From:* Armin Haller [mailto:armin.haller@anu.edu.au]
> *Sent:* Tuesday, 21 February, 2017 11:14
> *To:* Cox, Simon (L&W, Clayton) <Simon.Cox@csiro.au>;
> maxime.lefrancois@emse.fr; janowicz@ucsb.edu; public-sdw-wg@w3.org
>
>
> *Subject:* Re: Proposed solution to Issue-108 - Naming issues with
> observedBy
>
>
>
> There are some good proposals here in this thread for generalising the
> madeObservation property to be useful for Actuation and Sampling too. I
> would argue that these proposals are part of other Issues, i.e. *ISSUE-91
> <https://www.w3.org/2015/spatial/track/issues/91>* - Actuation and *ISSUE-92
> <https://www.w3.org/2015/spatial/track/issues/92>*, though.
>
>
>
> I would really want to close issue 108 first (one of the few I have raised
> myself), as it pertains only to a naming problem within SSN and SOSA with
> our inverseOf naming scheme.
>
>
>
> Personally, I tend to agree with Krzysztof to have two specific relations
> in SOSA at least for the Actuation and Observation case. For me they appear
> to be quite different, also in the modelling in SSN (e.g. in regards to
> Inputs and Outputs). However, whatever modelling we choose, if or if not we
> have specific properties in SOSA (and SSN), they can all be subproperties
> of a more general one or even a subproperty of prov:wasAssociatedWith,
> defined in the richer SSN.
>
>
>
>
>
> *From: *"Simon.Cox@csiro.au" <Simon.Cox@csiro.au>
> *Date: *Tuesday, 21 February 2017 at 10:33 am
> *To: *"maxime.lefrancois@emse.fr" <maxime.lefrancois@emse.fr>, "
> janowicz@ucsb.edu" <janowicz@ucsb.edu>, Armin Haller <
> armin.haller@anu.edu.au>, "public-sdw-wg@w3.org" <public-sdw-wg@w3.org>
> *Subject: *RE: Proposed solution to Issue-108 - Naming issues with
> observedBy
>
>
>
> Yes – a consistent pattern for naming would probably be helpful.
>
> But considering the issue of too many properties: a case could be made
> that they are all sub-properties of
>
>
>
> prov:wasAssociateFor / prov:wasAssociatedWith
>
>
>
> which therefore are the general case.
>
>
>
> Simon
>
>
>
> *From:* Maxime Lefrançois [mailto:maxime.lefrancois@emse.fr
> <maxime.lefrancois@emse.fr>]
> *Sent:* Tuesday, 21 February, 2017 08:04
> *To:* janowicz@ucsb.edu; Armin Haller <armin.haller@anu.edu.au>;
> public-sdw-wg@w3.org
> *Subject:* Re: Proposed solution to Issue-108 - Naming issues with
> observedBy
>
>
>
> OK,
> So you might be in favour of something like three pairs of properties with
> consistent naming:
>
> madeObservation / madeBySensor
> madeActuation / madeByActuator
> madeSamplingActivity / madeBySamplingDevice
>
> ?
>
> Could be fine with me. Although this rises the number of properties a bit
> too much in my opinion. I would still prefer fewer properties and proper
> documentation
> e.g., in the Observation class, document with: "can only be generated by
> Sensors"
>
> Kind regards,
> Maxine
>
>
>
> Le lun. 20 févr. 2017 20:42, Krzysztof Janowicz <janowicz@ucsb.edu> a
> écrit :
>
> Hi Maxime,
>
>
>
> On the other hand, shouldn't we start talking about two other renaming
> that could be important here to generalize to
> Observation/Actuation/SamplingActivity
>
>
>
> instead of madeObservation/madeBySensor , maybe something more general
> could save us the redefinition of these properties for
> Actuation/SamplingActivity
>
>
>
> For example: generated / isGeneratedBy ?
>
>
>
> I see your point here. Are you arguing for a general generated /
> isGeneratedBy relation for all the observation, actuation, and sampling
> cases? Personally, I strongly favor relations that are as specific as
> possible especially for SOSA (as it does not have anything formal to say
> about these relations). A typical anti-pattern would, for instance, be a
> general 'has' relations.  Clearly this is all not back and white. Maybe we
> can come up with a consistent naming schema and I think this is exactly
> what Armin proposed by madeObservation, madeBySensor, and so on. I agree
> that we would have to keep it similar for the Sampling part as well (if
> there would be such a need).
>
> Cheers,
> Jano
>
>
>
>
> On 02/20/2017 11:26 AM, Maxime Lefrançois wrote:
>
> Hi all,
>
>
>
> This looks good overall,
>
>
>
> If  the associated vote for this  wiki page is:
>
>
>
> "shall we rename oldssn:observedBy into some term that is the inverse of
> oldssn:madeObservation ?" then +1 for me
>
>
>
> On the other hand, shouldn't we start talking about two other renaming
> that could be important here to generalize to
> Observation/Actuation/SamplingActivity
>
>
>
> instead of madeObservation/madeBySensor , maybe something more general
> could save us the redefinition of these properties for
> Actuation/SamplingActivity
>
>
>
> For example: generated / isGeneratedBy ?
>
>
>
> a minor comment: in ssnx, some ssn prefixes should be changed to oldssn
>
>
>
> Kind regards,
>
> Maxime
>
>
>
> Le lun. 20 févr. 2017 à 07:02, Krzysztof Janowicz <janowicz@ucsb.edu> a
> écrit :
>
> Thanks Armin, these changes look good to me.
>
>
>
> On 02/19/2017 08:55 PM, Armin Haller wrote:
>
> Hi,
>
>
>
> I have created a wiki page (
> https://www.w3.org/2015/spatial/wiki/Naming_of_isObservedBy_vs_madeObservation_in_SOSA)
> that details a solution to Issue-108
> https://www.w3.org/2015/spatial/track/issues/108 that us SSN editors have
> agreed on.
>
>
>
> Please have a look at the solution to the small naming issue that resulted
> from the introduction of inverse properties in SOSA that clashed with a
> property name in SSN (observedBy) which itself has not been entirely
> consistent with the naming pattern in old SSN.
>
>
>
> If there are no objections, these changes will be implemented in SOSA and
> SSN and issue-108 closed.
>
>
>
> Kind regards,
>
> Armin
>
>
>
>
>
>
>
> --
>
> Krzysztof Janowicz
>
>
>
> Geography Department, University of California, Santa Barbara
>
> 4830 Ellison Hall, Santa Barbara, CA 93106-4060
>
>
>
> Email: jano@geog.ucsb.edu
>
> Webpage: http://geog.ucsb.edu/~jano/
>
> Semantic Web Journal: http://www.semantic-web-journal.net
>
>
>
>
>
> --
>
> Krzysztof Janowicz
>
>
>
> Geography Department, University of California, Santa Barbara
>
> 4830 Ellison Hall, Santa Barbara, CA 93106-4060
>
>
>
> Email: jano@geog.ucsb.edu
>
> Webpage: http://geog.ucsb.edu/~jano/
>
> Semantic Web Journal: http://www.semantic-web-journal.net
>
>
Received on Tuesday, 21 February 2017 11:38:59 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 21 February 2017 11:38:59 UTC