W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2013

Re: Figuring out easier readonly interfaces

From: Robert O'Callahan <robert@ocallahan.org>
Date: Mon, 14 Oct 2013 05:16:05 -0400
Message-ID: <CAOp6jLZM-BZqiDWzpBANhoctuZMuc94oHsfrvbksAV9h=LxxYw@mail.gmail.com>
To: "Mark S. Miller" <erights@google.com>
Cc: "Tab Atkins Jr." <jackalmage@gmail.com>, Allen Wirfs-Brock <allen@wirfs-brock.com>, "public-script-coord@w3.org" <public-script-coord@w3.org>
On Thu, Oct 3, 2013 at 4:55 PM, Mark S. Miller <erights@google.com> wrote:

> You lose the inability to mutate. If this inability to mutate was not part
> of the intended contract of the superclass, it should not use the term
> "read only".

"DOMRectReadOnly" means that this interface provides only read access to
the object. It says nothing about whether there are ways to mutate the
object, whether through other interfaces on the same object or via related
DOM objects (e.g. when a DOMRectReadOnly is returned by the "bounds"
attribute of a mutable DOMQuad). This name may be confusing, but it will be
seldom used by Web authors so I don't think it matters much as long as spec
authors and browser implementers understand.

This thread petered out, but we need to resolve the issue. No-one has
proposed any better naming convention AFAIK. I think we should go with
DOMRectReadOnly until someone puts forward a name they think is better.

Jtehsauts  tshaei dS,o n" Wohfy  Mdaon  yhoaus  eanuttehrotraiitny  eovni
le atrhtohu gthot sf oirng iyvoeu rs ihnesa.r"t sS?o  Whhei csha iids  teoa
stiheer :p atroa lsyazye,d  'mYaonu,r  "sGients  uapr,e  tfaokreg iyvoeunr,
'm aotr  atnod  sgaoy ,h o'mGee.t"  uTph eann dt hwea lmka'n?  gBoutt  uIp
waanndt  wyeonut  thoo mken.o w  *
Received on Monday, 14 October 2013 09:16:33 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:18 UTC