W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2013

Re: Figuring out easier readonly interfaces

From: Robert O'Callahan <robert@ocallahan.org>
Date: Thu, 3 Oct 2013 12:01:25 -0400
Message-ID: <CAOp6jLZbTKmYA1NTraXBHiAa62j0mmbWDsSi41S0baYe_fr6aw@mail.gmail.com>
To: "Mark S. Miller" <erights@google.com>
Cc: "public-script-coord@w3.org" <public-script-coord@w3.org>
On Thu, Oct 3, 2013 at 11:55 AM, Mark S. Miller <erights@google.com> wrote:

> If that's what you mean, then it definitely needs a better name. If roFoo
> is an instance of a ReadOnlyFoo or a FooReadOnly, then if you give me that
> instance, you should know that you've given me only the ability to observe
> mutations, but not the ability to cause them. If we don't need FooReadOnly
> or FooImmutable now, let's postpone them. But let's not use up these names
> to describe instances that don't provide these guarantees.

Very well. What name do you suggest for the read-only APIs of a DOMRect?

Jtehsauts  tshaei dS,o n" Wohfy  Mdaon  yhoaus  eanuttehrotraiitny  eovni
le atrhtohu gthot sf oirng iyvoeu rs ihnesa.r"t sS?o  Whhei csha iids  teoa
stiheer :p atroa lsyazye,d  'mYaonu,r  "sGients  uapr,e  tfaokreg iyvoeunr,
'm aotr  atnod  sgaoy ,h o'mGee.t"  uTph eann dt hwea lmka'n?  gBoutt  uIp
waanndt  wyeonut  thoo mken.o w  *
Received on Thursday, 3 October 2013 16:01:55 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:18 UTC