W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > March 2012

Re: Preliminary EARL report

From: Gregg Kellogg <gregg@kellogg-assoc.com>
Date: Sat, 17 Mar 2012 15:07:19 -0400
To: Niklas Lindström <lindstream@gmail.com>
CC: Manu Sporny <msporny@digitalbazaar.com>, public-rdfa-wg WG <public-rdfa-wg@w3.org>
Message-ID: <EA4AB023-7CDC-43FF-BF5D-7CCFE1BECFE4@greggkellogg.net>
On Mar 17, 2012, at 11:41 AM, Niklas Lindström wrote:

> Hello!
> 2012/3/15 Gregg Kellogg <gregg@kellogg-assoc.com>:
>> It runs quite fast against many of the host languages, but doesn't seem to return for HTML4 or XHTML1; any idea why that might be? It seems to return 503 "Service Unavailable".
> Yes, at the time I only used the standard XML parsing support in Java.
> Ad the XHTML failed because it tried to fetch the XHTML DTD. I have
> now included NekoHTML to support HTML, and turned off the DTD
> fetching. So I can happily report that clj-rdfa passes all tests for
> all markup flavours! Well, except for #0198 in XHTML5...
>> Regarding Test 0198, mine returns the following:
>> @base <http://rdfa.info/test-suite/test-cases/rdfa1.1/xhtml1/0198.xhtml> .
>> @prefix foaf: <http://xmlns.com/foaf/0.1/> .
>> @prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
>> <http://www.example.org/me#mark> a foaf:Person;
>>   foaf:firstName "Mark";
>>   foaf:name "<span xmlns=\"http://www.w3.org/1999/xhtml\" xmlns:foaf=\"http://xmlns.com/foaf/0.1/\" xmlns:rdf=\"http://www.w3.org/1999/02/22-rdf-syntax-ns#\" property=\"foaf:firstName\">Mark</span> <span xmlns=\"http://www.w3.org/1999/xhtml\" xmlns:foaf=\"http://xmlns.com/foaf/0.1/\" xmlns:rdf=\"http://www.w3.org/1999/02/22-rdf-syntax-ns#\" property=\"foaf:surname\">Birbeck</span>"^^rdf:XMLLiteral;
>>   foaf:surname "Birbeck" .
>> For XHTML1 and XHTML5, This does include an @xmlns, and it passes the test; what is it that you think should be different?
> In the test suite data, the markup includes the expected @xmlns when
> requested as </test-suite/test-cases/rdfa1.1/xhtml1/0198.xhtml>, but
> it is missing in </test-suite/test-cases/rdfa1.1/xhtml5/0198.xhtml>.
> Implementation-wise, it seems that if the template
> "lib/views/test_case.xhtml.haml" was used, it would add this. But in
> core.rb, the "when 'xhtml'" case doesn't for xhtml5. Isn't that a bug?

I'm not using those templates anymore, so that shouldn't be the cause of anything. (I'll remove them from the repo).

I fixed the xhtml5 code generation, as you indicated it should have an @xmlns. Thanks for catching this!


> Best regards,
> Niklas
>> Gregg
>> On Mar 14, 2012, at 4:56 PM, Niklas Lindström wrote:
>>> Hello!
>>> 2012/3/14 Gregg Kellogg <gregg@kellogg-assoc.com>:
>>>> On Mar 14, 2012, at 8:28 AM, Niklas Lindström wrote:
>>>>> My problems are related to multilines, and these tests pass if I run
>>>>> them manually using ARQ [2].
>>>> Do you think the SPARQL is wrong, or that the processor isn't interpreting this properly? Send me your result output and I'll check it out.
>>> The culprit was the mime-type I sent: "text/plain; charset=utf-8".
>>> While "text/plain" is for ntriples, I actually produce turtle-style
>>> UTF-8 literals using triple quotes when encountering newlines. So I
>>> corrected that to "text/turtle" and all those tests pass as well! I'm
>>> down to only one remaining now:
>>>>> Other than that, my implementation only
>>>>> fails on Test 0198 [3], which is missing an @xmlns. That may be a bug
>>>>> in the test though?
>>>> Yes, I think it is. I'll look at that.
>>> If xmlns="http://www.w3.org/1999/xhtml" is added to "tests/0198.txt",
>>> clj-rdfa will pass all the tests. (Yay!)
>>> I have deployed my implementation to Heroku (the free option, so it
>>> might take a while to start up at times). It might be good to set up a
>>> proper domain for it before it's ready to be added to the harness
>>> though. But you can try it out now by using
>>> "http://clj-rdfa.herokuapp.com/extract.ttl?url=" as the value for
>>> 'other' processor.
>>> (I'm also improving the interface for it so it can be seamlessly used
>>> in plain Java, and thus adapted to RDF libraries such as Jena and
>>> Sesame. When that's done it'll be a working RDFa 1.1 option for Java
>>> in general.)
>>> Best regards,
>>> Niklas
Received on Saturday, 17 March 2012 19:08:01 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:05:30 UTC