W3C home > Mailing lists > Public > public-rdf-wg@w3.org > September 2011

Re: today's minutes available

From: Sandro Hawke <sandro@w3.org>
Date: Wed, 28 Sep 2011 19:56:52 -0400
To: Arnaud Le Hors <lehors@us.ibm.com>
Cc: public-rdf-wg@w3.org
Message-ID: <1317254212.31898.108.camel@waldron>
On Wed, 2011-09-28 at 15:35 -0700, Arnaud Le Hors wrote:
...
> Finally, although I don't know what actually triggered Sandro's question 
> about whether the file contains the complete graph or not, it seems to me 
> that the {} proposal makes it look like what I'm seeing is the complete 
> graph when it may not be. I know it's up to us to define that there is no 
> such implication but I'd rather select a syntax that is more intuitive and 
> less likely to mislead a casual reader/user who may not have read the spec 
> carefully enough.

I agree that {} makes it look more complete, but fwiw, I think what's
needed is a way to make it complete....   Maybe this should be a new
ISSUE.    I can see reasons one might want both, but it's easy to go
from complete to incomplete with a subgraph relation, and I'm not sure
how to go from incomplete to complete.  I guess with pointing to the
file you got it from, which seems much trickier.

That is, if I need to say that G1 is exactly <s> <p> <o> and G2 contains
<s> <p> <o> and maybe some other triples, I can easily say:

(making up two new syntaxes for clarity...)

   G1 @isGraph { <s> <p> <o> }.
   G2 subGraph G1.

but it seems trickier to say:

   G2 @hasTriples { <s> <p> <o> }.
   G1 .... something about G2 and this file...?

I also like the @graph syntax as being more turtle-ish, but I worry
about this aspect of it.

      -- Sandro
Received on Wednesday, 28 September 2011 23:57:01 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:04:08 UTC