Re: Review of SD document (ACTION-318)

On Sep 28, 2010, at 9:28 AM, Alexandre Passant wrote:

>>> "An instance of sd:Language represents a subset of the SPARQL language" => I'd suggest "An instance of sd:Language represents one of the SPARQL languages"
>> I think the wording here came from a HCLS use case from ericP where we wanted a way to be able to describe not just the Query/Update distinction, but specific configurations of SPARQL w.r.t. optional features and/or extensions. I'm not sure of a better way to word this without actual examples of such configurations. Any thoughts?
> Ok, I See.
> Maybe "one of the SPARQL language, including specific configuration providing particular features or extension" ?

Yes, I like that better than what's there. Updated.

>>> Descriptions of domain / ranges (such as "sd:defaultEntailmentRegime is an rdfs:subPropertyOf sd:feature. The rdfs:domain of sd:defaultEntailmentRegime is sd:Service. The rdfs:range of sd:defaultEntailmentRegime is sd:EntailmentRegime.") may be more readable using bullet points / several lines
>> This has been brought up several times. I formatted it this way just for consistency with the syntax of the RDFS document. Is there existing list-formatting in other specs that you'd prefer, or do you think I should just try to hack up some html myself?
> Right, sorry, I realised I brought that up at the previous review.
> I'm more used to specs like FOAF (w/ domain / ranges on several lines, as in ) but I'm OK with the current one if no one else objects, as that's just a matter of taste.

Well, I'd just as soon update it to avoid more people raising the same issue later on. I'll look into some better formatting for this information.


Received on Wednesday, 29 September 2010 19:48:11 UTC