W3C home > Mailing lists > Public > public-qt-comments@w3.org > November 2016

Re: [FO31] array:join – misleading name?

From: Michael Kay <mike@saxonica.com>
Date: Wed, 30 Nov 2016 17:24:52 +0000
Cc: public-qt-comments@w3.org
Message-Id: <6EAAC8E6-43B1-4828-8DFB-BF4D5701859D@saxonica.com>
To: Thomas Fischer <fischer.th@gmail.com>
Thanks for the comment, logged at:


Provisional personal response:

Thanks for the feedback but I fear it is too late now to make cosmetic changes like this; the cost of making the change exceeds any benefit.

Michael Kay

> On 30 Nov 2016, at 16:20, Thomas Fischer <fischer.th@gmail.com> wrote:
> Hi,
> The documentation for array:join says:
>     Concatenates the contents of several arrays
> and "concat" is a common term for such functionality for arrays, whereas "join" is common to join the elements of an array into a string, separated by a specified separator.
> Therefore I would propose:
>   array:join($array as array(*)) as xs:string
>   array:join($array as array(*), $separator as xs:string) as xs:string
>   array:concat($arrays as array(*)*) as array(*)
> salute
> Th. Fischer
Received on Wednesday, 30 November 2016 17:25:23 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:58:03 UTC