W3C home > Mailing lists > Public > public-qt-comments@w3.org > February 2009

[Bug 6469] [FT] TestSuite issues

From: <bugzilla@wiggum.w3.org>
Date: Wed, 04 Feb 2009 21:48:09 +0000
To: public-qt-comments@w3.org
Message-Id: <E1LUpbN-0007s5-5I@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=6469





--- Comment #2 from Christian Gruen <christian.gruen@gmail.com>  2009-02-04 21:48:08 ---
Dear Pat,

thanks a lot for the prompt reply! As usual, just a small comment..

[18] ftwildcard-q2.xq
[19] ftwildcard-q5.xq

> --This query looks for "site." site followed a period (not an indicator). 
> There is a sites. The title ends in site but does not end in a period. I 
> don't see "site." in Book 2. [...]

This is an interesting point for discussion. I had another look into the XQFT
Tokenization section (4.1). If I get it right, the tokenizer won't care about
characters which are not part of tokens; so I would expect the two following
queries to return true:

  'a b' ftcontains 'a.b' 
  'a.b' ftcontains 'a b' 

This is why I would expect the dot in "site." to be ignored in the default
(without wildcards) mode. - Please tell me if I got something wrong.

Thanks again,

Christian, BaseX Team 
http://www.basex.org


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Wednesday, 4 February 2009 21:48:19 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:26 UTC