W3C home > Mailing lists > Public > public-qt-comments@w3.org > June 2006

[Bug 3315] [XqueryX] spurious "as" in typeswitch clause with no variable

From: <bugzilla@wiggum.w3.org>
Date: Tue, 13 Jun 2006 18:04:50 +0000
CC:
To: public-qt-comments@w3.org
Message-Id: <E1FqDFy-0005PM-Ks@wiggum.w3.org>

http://www.w3.org/Bugs/Public/show_bug.cgi?id=3315


jim.melton@acm.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXED




------- Comment #6 from jim.melton@acm.org  2006-06-13 18:04 -------
Thank you again for reporting this bug.  The XML Query WG has reviewed the
report and has endorsed a solution making certain changes to both the XML
Schema and the XSLT stylesheet for XQueryX. 

In the interests of ensuring that the entire community has access to the most
current version of the XQueryX schema and stylesheet, I am attaching both of
those as responses to this bug. 

Please inspect the attached Schema and stylesheet, especially the element
definition for "typeswitchExprCaseClause" and the templates for element
"typeswitchExprCaseClause" and for element "xqx:variableBinding". 

We believe that these changes resolves this bug.  I have marked the bug as
FIXED and request that you mark it CLOSED at your earliest opportunity.  If you
disagree with the solution, please add a new comment explaining your reasons. 
Received on Tuesday, 13 June 2006 18:04:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:57:12 UTC