W3C home > Mailing lists > Public > public-qt-comments@w3.org > December 2003

RE: [F&O] 15.1.8 fn:exists

From: Ashok Malhotra <ashokma@microsoft.com>
Date: Fri, 5 Dec 2003 09:25:20 -0800
Message-ID: <EDB607C8AC991F40BE646533A1A673E8C5A41F@RED-MSG-42.redmond.corp.microsoft.com>
To: "Dimitre Novatchev" <dnovatchev@yahoo.com>, <public-qt-comments@w3.org>

Dimitre:
My apologies!  Re. the example in 15.1.8.1, $seq is defined at the start
of 15.1 before 15.1.1.  The wording now says that $seq is non-empty. 

All the best, Ashok

-----Original Message-----
From: Dimitre Novatchev [mailto:dnovatchev@yahoo.com] 
Sent: Friday, December 05, 2003 9:11 AM
To: Ashok Malhotra; public-qt-comments@w3.org
Subject: RE: [F&O] 15.1.8 fn:exists


--- Ashok Malhotra <ashokma@microsoft.com> wrote:
> Dimitre:
> Thank you for your comment.  We discussed this on the 12/2/2003 telcon
> and decided not to change the name of the function.  "empty" is as
> imprecise a word as "exists" 

Ashok,

Thanks for considering my comment.

> and it did not seem that a change in the
> name of the function would benefit our users.

I am one of your users. How many other users did you contact and got
their
feedback that this change in the name wouldn't benefit them? If other
users were not contacted then what is the model of a user the WG has, on
the basis of which your conclusion was made?

> 
> All the best, Ashok

This does not address the second part of my original comment, which
treated the correctness of example 15.1.8.1


Thanks,

Dimitre Novatchev.



> 
> -----Original Message-----
> From: public-qt-comments-request@w3.org
> [mailto:public-qt-comments-request@w3.org] On Behalf Of Dimitre
> Novatchev
> Sent: Saturday, November 22, 2003 5:09 AM
> To: public-qt-comments@w3.org
> Subject: [F&O] 15.1.8 fn:exists
> 
> 
> There are two issues with this function:
> 
>  1.  The function name does not accurately reflect its semantic - it
> does
>      not provide an answer if a sequence exists, but if a sequence 
>      is non-empty.
> 
> Because 
>    
>      not(empty($seq)) = exists($seq)
> 
>      a better name for this function would be notEmpty() or nonEmpty()
> 
>  2. The example in 15.1.8.1 is incorrect:
> 
>     "fn:exists($seq) returns true."
> 
> The above statement is true only if $seq is non-empty and $seq has not
> been defined. One can incorrectly deduce that the function returns
true
> for any sequence.
> 
> 
> Dimitre Novatchev.
> 
> 
> 
> 
> 
> __________________________________
> Do you Yahoo!?
> Free Pop-Up Blocker - Get it now
> http://companion.yahoo.com/
> 


__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/
Received on Friday, 5 December 2003 12:25:25 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:45:15 UTC