Re: Multiple XML schema files for a common target namespace (PROV-ISSUE-608)

On Tue, Feb 12, 2013 at 8:57 PM, Stephan Zednik <> wrote:

> 1) rename prov:abstractElement to prov:internalElement (or similar) to make it clear we do not expect non-PROV extensions to use this element.

+1  (I'm in favour of keeping the abstract element for internal PROV
extensions rather than my suggested additional xs:any)

> 2) add processContents="lax" on all xs:any elements.


> 3) change the definition of prov:Bundle to the following (bundleElements name is not final)

0 - I'm rather in favour of Luc's proposal later in this thread to
separate the bundle entity from the bundle constructor. I would prefer
<bundleDescriptions> rather than <bundleConstructor> as the children
of this element would be the provenance descriptions - matching DM
"descriptions: a set of provenance descriptions".
<somethingConstructor> reads odd in XML, I've only seen something
similar in Spring configuration of java beans, where a class
constructor is to be programmatically called.

Stian Soiland-Reyes, myGrid team
School of Computer Science
The University of Manchester

Received on Wednesday, 13 February 2013 00:00:38 UTC